veit > microsoft.public.* > microsoft.public.office.excel

 #1  
05.11.2003, 21:44
Guus
Beste exel kunstenaars,

In mijn exel bestand met aardig wat tabbladen probeer ik op een van die
bladen middels vertikaal
zoeken gegevens op te halen vamuit een blad met genummerde kolommen van 1
t/m 8
Onder de rij met nummers een rij met namen
1 2 3
Naam, Adres, Postcode zoiets dus
Nu heb ik een rolmenu met validatie van die lijst met namen en dat werkt
dus.
De bedoeling is dat ik bijv de naam , adres per persoon uit m,n rolmenu met
vertikaal zoeken "ophaal"

Het tabblad met gegevens heet samenvoeggevens en waar ik het in wil hebben
heet bedankbrief.
Met invoegen funcie enz kom ik er niet uit want weet niet wat ik in moet
vullen en exel help help me niet verder.

Toen maar zelf ingevuld :
=VERT.ZOEKEN($?$;'SAMENVOEGGEGEVENS'!A1:K600;ONWAA R)

Bedankt voor de genomen moeite.

<<<Outgoing and incoming mail scanned by Norton pro>>>
 #2  
05.11.2003, 21:58
Luc.Heyndrickx
Guus,

De $?$ uit uw formule heb je toch gewoon te veranderen in het celadres dat
je gevalideerd hebt?
En voor het argument ONWAAR heb je nog een argument nodig: nml de kolomindex
(Daar waar de te zoeken gegevens zich bevinden in je tabel).
Zal dus iets worden als:
=VERT.ZOEKEN(A1;'SAMENVOEGGEGEVENS'!A1:K600;2;ONWA AR)

Nog een tip: Indien je niet goed weet hoe een functie werkt, gebruik dan de
wizzard.
Invoegen => Functie ... enz.

Op die manier heb je nooit te weinig argumenten, en bovendien krijg je hulp
van Excel zelf.

Luc

"Guus" <guusvandijk> schreef in bericht
news:eedf
[..]
 #3  
06.11.2003, 00:06
Guus
Dank voor de tips Luc maar moet sheet met gegevens als eerste tabblad staan
?
Hij staat nu op de 22 plaats .
De formule geeft geen foutmelding of zo maar geeft alleen een 0 ( nul) als
resultaat.
Wat betreft de wizard , dan krijg ik een menu met 4 invoervakken waarbij ik
niet weet wat er
precies mee bedoeld wordt.Ook in exel help kom ik geen stap verder.

Guus

"Luc.Heyndrickx" <lucDitVerwijderenheyndrickx> schreef in bericht
news:2652
[..]
 #4  
06.11.2003, 00:22
Luc.Heyndrickx
Guus,

Toch maar de Wizzard gebruiken.
Wat VERT.ZOEKEN betreft:

Het eerste vak is het adres van de waarde die je ook in je tabel wil zoeken.
Nu moet je effe opletten. Indien je in dit vak een celverwijzing zet, zie
je onmiddelijk rechts van dit vak de waarde die in die cel gevonden wordt.
En indien je dit vak selecteert, zie je onderaan de wizzard de uitleg wat
daar moet komen.
Het tweede vak is de tabel. Ook hier let je op de info rechts en onderaan.
Derde vak is de kolom waar gezocht moet worden. Het betreft hier de
hoeveelste kolom in je tabel. Weer letten op rechts en onderaan.
Vierde vak is gewoon ONWAAR. Maak u hier voorlopig nog geen zorgen over.
Op het ogenblik dat je voldoende gegevens hebt ingevuld, zie je in dezelfde
wizzard ook meteen het resultaat.

Ik weet dat Excel niet steeds even duidelijk is, zeker niet als je het niet
gewoon bent, maar ik zou het zelf echt niet beter kunnen uitleggen.
Hetgeen je leert door dit goed te gebruiken, kan je ook toepassen op alle
andere functies, en hierdoor zal je meer hebben geleerd dan enkel
VERT.ZOEKEN.

Luc

"Guus" <guusvandijk> schreef in bericht
news:eedf
[..]
 #5  
06.11.2003, 08:44
Guus
Luc

Luc,

Zelfs als het invul menu geen fouten aangeeft ( in het rood) kom ik niet
verder dan #N/B als resultaat.
Ik heb hieronder een paar voorbeeldjes geplakt wellicht kunt u al direct de
fout zien.
Zo heb ik echt uren van alles geprobeerd maar zonder resultaat. Is de
tabblad -naam te lang misschien?

Oh Luc ik geloof dat ik het heb
De onderste formule was ik hier aan het plakken en zag ineens een atum (als
getal) staan. Celopmaak gewijzigd en ja hoor
pfffffffffff wat een formule zeg daar kom je toch niet op zonder het
invulmenu ?
Heb ik vanacht niet voor niets bijna niet geslapen

=VERT.ZOEKEN("Naam";SAMENVOEGGEGEVENS!A1;6;ONWAAR)

=VERT.ZOEKEN("Gegevens";SAMENVOEGGEGEVENS!2:2;6;ON WAAR)

=VERT.ZOEKEN(NAAM;2;6;ONWAAR)

=VERT.ZOEKEN(NAAM;M600;6;ONWAAR)

=VERT.ZOEKEN(SAMENVOEGGEGEVENS!A3;SAMENVOEGGEGEVEN S!1:65536;6;ONWAAR)

Guus

"Luc.Heyndrickx" <lucDitVerwijderenheyndrickx> schreef in bericht
news:1096
[..]
 #6  
06.11.2003, 09:48
Guus
Luc,

Ik dacht dat die grote formule werkte maar dat is niet juist. Hij geeft
alleen de horzintale gegevens per kolom weer.
Dus van maar een enkele rij ( persoon ) . En als ik dan de laatste enkele
zes (zie onder) verander in bijv. 4 geeft ie dus wel het resultaat van die
cel in kolom4 maar op de zelfde rij dus .
Ik was al zo blij en dacht het is niet te gelopven na zoveel uren
proberen......
Is er zo nog iets aante passen dat ie wel vericaal gaat zoeken ?
=VERT.ZOEKEN(SAMENVOEGGEGEVENS!A3;SAMENVOEGGEGEVEN S!1:65536;6;ONWAAR)
Guus

"Guus" <guusvandijk> schreef in bericht
news:eedf
[..]
 #7  
06.11.2003, 12:23
Ingrid Baplue
Even een woordje uitleg over de functie:

=VERT.ZOEKEN(zoekwaarde;tabelmatrix;kolomindex_get al;benaderen)

Het eerste argument, zoekwaarde, is de waarde waarnaar moet gezocht worden
in de eerste kolom van de tabelmatrix. Deze zoekwaarde kan een celverwijzing
zijn, maar kan dus niet verwijzen naar de eerste kolom in de tabelmatrix
(wat jij dus blijkbaar wel doet).

Uit het eerste bericht in deze thread versta ik dat de zoekwaarde in
hetzelfde werkblad staat als waarin de zoekformule staat, dus dan moet die
formule zo iets worden:

=VERT.ZOEKEN(A3;SAMENVOEGGEGEVENS!1:65536;6;ONWAAR )
 #8  
06.11.2003, 20:34
Guus
Hallo Ingrid

Helaas lukt dit niet.
De zoekwaarde is aanwezig op het tabblad SAMENVOEGGEGEVENS
Op dit tabblad staan de kolommen met gegevens kolom A t/m F
Deze zijn op de bovenste rij genummerd van 1/t/m 6
Op de tweede rij staan de "hoofdstukken" zoals hieronder.
NAAM ADRES POSTCODE PLAATS TELEFOONNUMMER CODE
GESTOPT

En ik wil vanuit het tabblad BEDANKBRIEF gegevens importeren via verticaal
zoeken
Dat is een brief waar dan de naam , adres,postcode -plaats en code ingevuld
moeten worden.
Ik hoop dat ik iets duidelijke ben met de lastige vraag.
Geen van de tabbladen staan overigens als eerste tabblad maar ik weet niet
of dat moet ?

"Ingrid Baplue" <ingrid_baplueGEENSPAM> schreef in bericht
news:2000
[..]
 #9  
07.11.2003, 00:28
Ingrid Baplue
Even alles op een rijtje:

Op het tabblad SAMENVOEGGEGEVENS staat de tabel waarin gezocht moet worden.
Deze tabel staat in A:F
De zoekwaarde moet dus gezocht worden in kolom A en de overeenkomende cel
moet worden weergegeven.
Het tweede argument 'tabelmatrix' is dus
SAMENVOEGGEGEVENS!A:F

Het eerste argument moet echter naar een cel verwijzen die NIET in de
tabelmatrix staat. Het kan zijn dat die cel in hetzelfde werkblad staat,
maar ZEKER NIET in kolom A, want daarin moet juist dezelfde waarde gezocht
worden. Je moet dus in een adere cel een naam invoeren en deze dan in de
tabelmatrix gaan zoeken.
 #10  
07.11.2003, 01:29
Guus
Hallo Ingrid,

Zeer bedankt voor je hulp!
Maar het lukt me nog steeds niet, er komt geen #N/B of zo maar wel de datum
van kolom 6 (F)
En dat blijft er staan of ik moet handmatig het laatste cijfer veranderen
dus zoals voorbeeld naar een
, twee , drie enz
Ik had in cel H10 LEUK getypt en dat als zoekwaarde opgegeven.
Het invulmenu zaf er ook zo uit:

SAMENVOEGGEGEVENS!H10
Tabelmatrix SAMENVOEGGEGEVENS!A:F
Kolomindexgetal een 1
en onderaan ONWAAR

=VERT.ZOEKEN(SAMENVOEGGEGEVENS!A3;SAMENVOEGGEGEVEN S!A:F;1;ONWAAR)
=VERT.ZOEKEN(SAMENVOEGGEGEVENS!A3;SAMENVOEGGEGEVEN S!A:F;6;ONWAAR)

En met onderstaand krijg ik weer wel #N/B
=VERT.ZOEKEN(SAMENVOEGGEGEVENS!H10;SAMENVOEGGEGEVE NS!A:F;1;ONWAAR)

Is er nog redding voor mij ?

"Ingrid Baplue" <ingrid_baplueGEENSPAM> schreef in bericht
news:8ep1
[..]
 #11  
07.11.2003, 09:45
Guus
Het wil maar niet lukken...en heb onder meer onderstaande formules gebruikt

Met deze is 0 het resultaat
=VERT.ZOEKEN(SAMENVOEGGEGEVENS!H5;SAMENVOEGGEGEVEN S!A:F;5;ONWAAR)
Met deze is 0 het resultaat
=VERT.ZOEKEN(SAMENVOEGGEGEVENS!G6;SAMENVOEGGEGEVEN S!A:F;6;ONWAAR)
Met deze is 0 het resultaat
=VERT.ZOEKEN(SAMENVOEGGEGEVENS!H5;SAMENVOEGGEGEVEN S!A:F;2;ONWAAR)
Met deze #N/B
=VERT.ZOEKEN(SAMENVOEGGEGEVENS!A5;SAMENVOEGGEGEVEN S!A2;ONWAAR)
Met deze #NAAM?
=VERT.ZOEKEN(SAMENVOEGGEGEVENS!A:FLEUK;SAMENVOEGGE GEVENS!A2;ONWAAR)
En met deze krijg ik #VERW!
=VERT.ZOEKEN(SAMENVOEGGEGEVENS!G5;SAMENVOEGGEGEVEN S!A:F;8;ONWAAR)
Tja en met deze verschijn er 04-01-00 in de bedankkbrief maar deze datum
komt in het geheel niet voor in SAMENVOEGGEGEVENS
=VERT.ZOEKEN(SAMENVOEGGEGEVENS!A1;SAMENVOEGGEGEVEN S!A:F;4;ONWAAR)

Ik snap er niets meer van het invulmenu vanuit functies verticaal zoeken
geeft bij deze formules geen "ongeldig"
(in het rood) aan maar er staat niets ingevuld bij resultaat (links onder)en
dus ook niet in het werkblad BEDANKBRIEF.

U ziet ik doe m,n best maar weet echt niet wat de verkeerde invoer is.

"Ingrid Baplue" <ingrid_baplueGEENSPAM> schreef in bericht
news:8ep1
[..]
 #12  
07.11.2003, 10:11
André
ik heb een modelletje in je emailbus gestopt
suc6
André

[..]
>"Ingrid Baplue" <ingrid_baplueGEENSPAM> schreef in bericht
>news:8ep1
>worden.

1:65536;6;ONWAAR)
het rood) kom ik
Norton pro>>>
[..]
Soortgelijke onderwerpen