veit > comp.* > comp.software.office

 #1  
13.06.2005, 12:38
Joolz
Hoi,

Ik heb een probleem met Excel 97. Ik moet de som berekenen van een
reeks waarden die in niet aaneengesloten cellen staan. Deze cellen
bevinden zich wel op een vaststaande afstand van elkaar. Voorbeeldje:

a1
a2
a3
a4
a5
a6
=som(a1:a3:a5)

Het noemen van alle cellen is zeer foutgevoeling, en aangezien het om
veel gegevens gaat, /gaat/ het ook fout :) Een oplossing is om van
a1:a3:a5 een range te maken met een naam en dan =som(Reeks). Echter...
het aantal cellen is te groot voor een reeks :( Wat ik zoek is een
functie die zoiets doet:

verticale_reeks(startcel, stapwaarde, eindcel)

bv. verticale_reeks(a1, 2, a6). Iemand enig idee hoe ik dit kan doen?
Thanks!
 #2  
13.06.2005, 13:03
Luc Heyndrickx
Hoi Joolz,

In de veronderstelling dat je getallen in de range (A1:A20) staan.
en je alle onpare rijen wil optellen... dan kan je deze matrix-formule
gebruiken:

=SOM((REST(RIJ(A1:A20);2)=1)*(A1:A20))

Invoeren, en afsluiten met de toestencombinatie: Ctrl Shift Enter
De Range lijkt me duidelijk om aan te passen.
Indien je alle pare rijen wil tellen, dan moet je die 1 vervangen door een 0
Ook elke derde rij (of vierde; vijfde enz.) kan je optellen. Dan moet je de
2 vervangen.

En vooral: Steeds afsluiten met de toetsencombinatie Ctrl Shift enter.

Luc

"Joolz" <root> schreef in bericht
news:514c
[..]
 #3  
13.06.2005, 15:36
Joolz
On Mon, 13 Jun 2005 12:03:48 +0200, Luc Heyndrickx <lucheyndrickxDitVerwijderen> wrote:
[..]
> 2 vervangen.
> En vooral: Steeds afsluiten met de toetsencombinatie Ctrl Shift
> enter.


Hoi Luc,

Alvast hartstikke bedankt, maar ik begrijp hem noeg niet helemaal
(waarschijnlijk door mijn rekenkunde-onknobbel :) De aanpak werkt,
maar ik kan de formule niet een cel omlaag kopieren, ook al gebruik ik
relatieve adressen. Een voorbeeld:

rij waarde / formule
1 1
2 2
3 3
4 4
5 5
6 4,00 {=SOM((REST(RIJ(A1:A3);2)=1)*(A1:A3))}
7 3,00 {=SOM((REST(RIJ(A2:A4);2)=1)*(A2:A4))}

De formule op rij 6 doet zijn werk, maar rij 7 komt met de uitkomst
3,00 terwijl ik 6,00 verwachtte. Hoe kan dit?

Alweer bedankt,

Joolz.
 #4  
13.06.2005, 16:18
Luc Heyndrickx
"Joolz" <root> schreef in bericht
news:514c
[..]
> 5 5
> 6 4,00 {=SOM((REST(RIJ(A1:A3);2)=1)*(A1:A3))}
> 7 3,00 {=SOM((REST(RIJ(A2:A4);2)=1)*(A2:A4))}
> De formule op rij 6 doet zijn werk, maar rij 7 komt met de uitkomst
> 3,00 terwijl ik 6,00 verwachtte. Hoe kan dit?
> Alweer bedankt,
> Joolz.


Toch komt het uit.

REST(RIJ(A2:A4);2)
Dit geeft de restwaarde indien je het rijnummer deelt door 2
Deel rij 2 door 2 dan krijg je 0
Deel rij 3 door 2 dan krijg je 1
Deel rij 4 door 2 dan krijg je 0

Nu maak ik de som van elke rij, waar de restwaarde 1 is
Vermits enkel rij 3 een restwaarde heeft, heb je de som van 3

Luc
 #5  
13.06.2005, 16:31
Joolz
On Mon, 13 Jun 2005 15:18:00 +0200, Luc Heyndrickx
<lucheyndrickxDitVerwijderen> wrote:
> "Joolz" <root> schreef in bericht
> news:514c
> Toch komt het uit.
> REST(RIJ(A2:A4);2)
> Dit geeft de restwaarde indien je het rijnummer deelt door 2
> Deel rij 2 door 2 dan krijg je 0
> Deel rij 3 door 2 dan krijg je 1
> Deel rij 4 door 2 dan krijg je 0
> Nu maak ik de som van elke rij, waar de restwaarde 1 is
> Vermits enkel rij 3 een restwaarde heeft, heb je de som van 3


Dan is de formule waarschijnlijk niet wat ik nodig heb... De bedoeling
was "geef de som van alle cellen binnen een bepaalde range met een
tussenruimte van x cellen".

Weet je daar misschien iets voor?
 #6  
13.06.2005, 16:56
Luc Heyndrickx
"Joolz" <root> schreef in bericht
news:514c
> On Mon, 13 Jun 2005 15:18:00 +0200, Luc Heyndrickx
> <lucheyndrickxDitVerwijderen> wrote:
> Dan is de formule waarschijnlijk niet wat ik nodig heb... De bedoeling
> was "geef de som van alle cellen binnen een bepaalde range met een
> tussenruimte van x cellen".
> Weet je daar misschien iets voor?


Tuurlijk... dezelfde formule. Maar dan moet je ze wel begrijpen.

=SOM((REST(RIJ(A1:A30);2)=1)*(A1:A30))

Geeft de som van alle getallen in onpare rijen binnen de range A1:A30

=SOM((REST(RIJ(A1:A30);2)=0)*(A1:A30))
idem als hierboven, maar nu met de pare rijen

=SOM((REST(RIJ(A1:A30);3)=0)*(A1:A30))
Geeft de som van elke derde rij in A1:A30

=SOM((REST(RIJ(A1:A30);3)=1)*(A1:A30))
Geeft de som van rij 1; 4; 7; 10 enz.

=SOM((REST(RIJ(A10:A30);3)=1)*(A10:A30))
Geeft de som van rij 10; 13; 16; 19 enz.

Luc
 #7  
13.06.2005, 17:32
Joolz
On Mon, 13 Jun 2005 15:56:13 +0200, Luc Heyndrickx <lucheyndrickxDitVerwijderen> wrote:
>=SOM((REST(RIJ(A1:A30);3)=1)*(A1:A30))
> Geeft de som van rij 1; 4; 7; 10 enz.


Bedankt voor je geduld, hopelijk is dat nog niet op :)

Het lijkt erop dat ik het niet begrijp, als ik dit doe:

cel waarde / formule
a1 1
a2 2
a3 3
a4 4
a5 5
a6 6
a7 7
a8 8
a9 9
a10 10
a11 11

{=SOM((REST(RIJ(A3:A11);4)=1)*(A3:A11))}

zou ik volgens mij de som van de a3, a7 en a11 moeten krijgen, maar
excel geeft 14 ?
 #8  
13.06.2005, 17:39
Luc Heyndrickx
"Joolz" <root> schreef in bericht
news:514c
[..]
> a7 7
> a8 8
> a9 9
> a10 10
> a11 11
> {=SOM((REST(RIJ(A3:A11);4)=1)*(A3:A11))}
> zou ik volgens mij de som van de a3, a7 en a11 moeten krijgen, maar
> excel geeft 14 ?


Je krijgt de som van rij 5 en rij 9

Rij 3/4 = rest 3
Rij 4/4 = Rest 0
Rij 5/4 = Rest 1.... dit moet je dus hebben
Rij 6/4 = Rest 2
Rij 7/4 = Rest 3
rij 8/4 = Rest 0
Rij 9/4 = Rest 1 ....dit moet je hebben

enz.

Luc
Soortgelijke onderwerpen